Not a member yet? Why not Sign up today
Create an account  

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
LOTR Online Port 1687 not working

Hello! Thank you for interacting with me on YouTube earlier today and for creating a port in the PortingKit library for The Lord of the Rings Online.

Yesterday, I successfully installed and ran the game using the "New Custom Port" option. After that, we interacted a bit on YouTube and you created the port for the library. Unfortunately, that is not working correctly. PortingKit failed to complete the installation shortly after I chose the installer file (which was sitting in my ~/Downloads folder). Here is the log:
----- ----- ----- ----- -----
2023-09-09 16:30:37.13700 - INFO: Computer details:

Porting Kit Version: 5.13.8
Computer Model: iMac19,2
Processor: Intel Core i3-8100 3.6GHz
RAM Memory: 32Gb
Disk Size: 1.9Tb (1.9Tb available)
Operating system: macOS 13.5.2 (22G91)
Video cards:
- Radeon Pro 555X (2048 MB)

2023-09-09 16:30:37.13800 - INFO: Downloading wrapper (if needed)
2023-09-09 16:30:37.98500 - INFO: Downloading WS11WineCX64Bit22.1.1-13...
2023-09-09 16:30:37.98600 - INFO: Copying wrapper to /var/folders/8n/25pzgyxs4350smm_vhhwbn640000gp/T/
2023-09-09 16:30:38.62900 - ERROR: Cannot read properties of undefined (reading 'toString')
TypeError: Cannot read properties of undefined (reading 'toString')
    at (/Applications/Porting
    at _0x277982._0x785b6c.<computed> [as runNextStep] (/Applications/Porting
    at _0x277982._0x785b6c.onStepCompleted (/Applications/Porting
    at /Applications/Porting
----- ----- ----- ----- -----
After trying several times with 1687 and seeing the identical failure and console output, I used the "New Custom Port" option and was able to successfully install and run LOTRO. After that, I again tried installing with library entry 1687 and the installation failed in the same way.

Thank you again for your time and attention! I do hope you can repair 1687. I am looking forward to testing the next version of it.

Best wishes,
John H

I have noted that the library entry for The Lord of the Rings Online is "LOTR Online". Most players of The Lord of the Rings Online are unlikely to find it with that name. If possible, I suggest that the name for library entry 1687 be changed to "LOTRO - The Lord of the Rings Online". That should cover the most common terms used to search for this game, which are "LOTRO" and "Lord of the Rings" and, less commonly, the full name "The Lord of the Rings Online".

I just now (Mon 11 Sep 11:00am EDT) tried again and you must have made additional changes to 1687 because the installation proceeded successfully. I did not have to point PortingKit to the installer file in my ~/Downloads folder, that was downloaded as part of the installation process.

Unfortunately, while the installation proceeded properly, once PortingKit completed the installation and I attempted to run LOTRO from within the PortingKit interface, nothing visible happened at all. I then quit PortingKit and attempted to run LOTRO by double-clicking the wrapper and again nothing visible happened at all. The game failed to run.

Since I can still install and run the game using PortingKit's "New Custom Port" option, there must still be something wrong with the script in 1687. So progress has been made! But we're not there yet.

Thank you again for the time you are putting into this. Please let me know if there is any information I can provide or specific tests I can run which might assist.

The current version of 1687 is working perfectly!

Forum Jump:

Users browsing this thread:
1 Guest(s)